2011
07
13

FireFox 5 以降で RoboForm 6 を使う方法

Firefox4_help.jpg

Roboform 6 系プロ(永久ライセンス)をお使いの方で、 Firefox 5 系が対応していないことにお嘆きの方へ。


「購入すれば永久アップデート」だった旧 Ver.6 系までの Roboform Pro ですが、「ついに」というべきか?更新終了となっちゃいましたね。
UI も新しくなった「ロボフォーム セブン」 からは、年単位での課金更新となっています。
また同時に、 Firefox の「高速リリースサイクル」化によって、 FF 4 以降は「ツールバー(自動入力)」も効かなくなるという結果に。


★互換方法の説明に入る前に、「更新」もしくは「新規購入」をご紹介しときます。
下の互換方法が判らないようなら、悩まずに新版を購入すべきですよ!

・ 2010年9月以降にV6を購入の方は、「セブン」への無料切替を申請できるようです。
http://support.roboform.com/php/rtss/main/?lang=jp

・本家 Siber Systems さん購入ページ(日本語・日本円)
http://www.roboform.com/php/pums/rfprepay.php?lang=jp&lic=default¤cy=JPY
オンライン化データで台数制限なしの「エブリウェア」なら、新規購入でも初年度 \1,250 ですよ。

・国内代理店のイプログダイレクトさんからなら、銀行振込(ネットバンキング・要消費税)も対応します。
http://direct.eprog.com/catalog/index.php?osCsid=532d18ce075e23be15f559d26424170e



さて、Firefox 5 系への互換方法ですが、 mozilla サポートフォーラム(本家)でも、その質疑応答がありました。
( Top 画像の場所:開始当時は Firefox 4 系の話題)
http://support.mozilla.com/ja/questions/749215#


FF4_xpi_RBF6.jpg
ちなみに Firefox 4 更新時においては、一旦は公式対応パッチ(?)があったようです。
http://www.roboform.com/dist/roboform-firefox-3-4-frozen.xpi


対応方法の記述(応答)はこちら
FF_Help_Forum_A.jpg
非常に単純ですが、内容として初心者向きではないので、詳細解説は致しません。
基本的に画像(もしくは同ページ)を読んで下さい。
まぁ、「プログラムファイル」中の「 FireFox 」(アドオン)フォルダをまるごと置き換えるだけですね。
(文中では ver7.2.7 の記載ですが、現行 7.3.2 も同様動作です)

結果としてこうなります
RBF7_on_FF5.jpg


なお、以前の記事でも紹介しましたが、 install.rdf ファイルを直接編集するも有効。
RBF6_on_FF5.jpg
6 系のツールバー(アドオン)でも、 Firefox 5 上で動作させることは可能。

というか、ver7.3.2 の install.rdf ファイルを確認したら「 5.9 」までの対応版でしたので、以降(=年内)は書き換え作業が必須になるはずです。
なお書き換えの際は、変更値適用のため「 Profile 」フォルダにある extensions.rdf の削除をお忘れなく!(次回起動時に自動生成)



他人に知られたくないセキュアな情報管理には、専用の暗号化ストレージに保管するという方法もありますね。







スポンサーサイト

«  | HOME |  »